Web app performance degradation
Incident Report for ChartMogul
Resolved
This incident has been resolved.
Posted Jul 19, 2019 - 17:10 CEST
Investigating
We're currently investigating a potential performance degradation of our web application. This incident will be updated accordingly as the investigation progresses.
Posted Jul 19, 2019 - 08:38 CEST
This incident affected: ChartMogul App.