Customers are not able to create a new account
Incident Report for ChartMogul
Resolved
This incident has been resolved.
Posted Nov 05, 2021 - 00:28 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 05, 2021 - 00:19 CET
Investigating
We are currently investigating this issue.
Posted Nov 04, 2021 - 22:40 CET
This incident affected: ChartMogul App.