Google SSO login experiencing issues

Minor Incident ChartMogul App
2026-08-31 11:15 CEST · 2 hours, 12 minutes

Updates

Resolved

This issue has been resolved.

August 31, 2026 · 13:26 CEST
Update

We’ve identified the problem and we’re working on a fix.

August 31, 2026 · 12:29 CEST
Investigating

Users may be experiencing issues logging into ChartMogul via Google SSO. We’re investigating the problem.

August 31, 2026 · 11:42 CEST

← Back