Data Processing Delays - Reporting Tools Affected
Minor Incident
ChartMogul App
ChartMogul API
Integration Services
Chargebee Service
App Store Connect Service
GoCardless Service
Google Play Service
PayPal Integration
2025-12-12 08:20 CET
· 7 hours, 37 minutes
Updates
Resolved
December 12, 2025 · 15:56 CET
Processing speed back to normal. No further investigation is needed.
Issue
December 12, 2025 · 08:23 CET
Our data processing infrastructure is running behind which is causing inaccuracies in the reporting tools. No data has been lost and the system. We are currently investigating.
← Back
ChartMogul Status