Web app performance degradation
Incident Report for ChartMogul
Resolved
This incident has been resolved.
Posted Jul 01, 2019 - 22:29 CEST
Investigating
We're currently investigating a potential performance degradation of our web application. This incident will be updated accordingly as the investigation progresses.
Posted Jul 01, 2019 - 22:25 CEST
This incident affected: ChartMogul App.