Delay with Google Play sources
Minor Incident
Integration Services
Google Play Service
2025-03-19 20:21 CET
· 13 hours, 48 minutes
Updates
Resolved
March 20, 2025 · 10:08 CET
The multi-day delay with Google play (sales reports) is now resolved and we have backfilled all the data for impacted customers.
Update
March 20, 2025 · 08:55 CET
The delay with Google Play sales report updates seems to be improving. The team is in the process of checking all impacted accounts and backfilling the data as of March 15th where necessary. We will continue to share updates accordingly.
Monitoring
March 19, 2025 · 20:21 CET
We are monitoring a delay in data getting updated in Google Play (sales reports) over the last few days, which could be impacting a subset of our customers. The team is investigating.
← Back