Processing delays

Minor Incident ChartMogul App ChartMogul API
2025-03-13 19:59 CET · 54 minutes

Updates

Resolved

This incident has been resolved.

March 13, 2025 · 20:53 CET
Monitoring

The issue has been identified and fixed. We’re monitoring the affected systems.

March 13, 2025 · 20:14 CET
Issue

Some accounts may experience delays in data processing. We are actively working to restore normal processing speeds.

March 13, 2025 · 19:59 CET

← Back