Email outage
Major Incident
ChartMogul App
2024-11-28 15:52 CET
· 36 minutes
Updates
Resolved
November 28, 2024 · 16:27 CET
The issue has been resolved. Email service is back to normal.
Issue
November 28, 2024 · 15:52 CET
Emails are currently not being sent out of ChartMogul due to an issue with our email provider SendGrid.
← Back