Email outage

Major Incident ChartMogul App
2024-11-22 04:15 CET · 1 hour, 58 minutes

Updates

Resolved

SendGrid unblocked our account. Email notifications are back to normal

November 22, 2024 · 06:13 CET
Issue

Emails are currently not being sent out of ChartMogul due to an issue with our email provider SendGrid

November 22, 2024 · 04:15 CET

← Back