Processing delays

Minor Incident ChartMogul App ChartMogul API
2023-10-23 09:00 CEST · 2 hours, 34 minutes

Updates

Resolved

We have addressed the issue and delays are back to normal.

October 23, 2023 · 11:34 CEST
Investigating

Up to 20 % of accounts experience delayed processing. We’re deploying a fix.

October 23, 2023 · 11:18 CEST

← Back